Objective: To create RDLC reports 

Scenario: We will create a simple library management system. The system has three master tables i.e. BookCategory, Book and Member and two master detail tables. BookCategory stores al categories of the books. Book master table stores all the data related to book. Member Master stores all data related to library members. And Master Detail Table will store the data about Issue In and Issue Out. 

In this tutorial we are creating RDLC reports. 
1. Start:
1. Open your Input_RDLCReport.ath file and jump to Step 11 or Go to step 2.

2. Setting Project Properties: In this step we are setting project properties such as setting path for project file, applying themes for the project etc.

1. Click on “File -> Project Properties” menu from Author Main Window.

2. Enter “RDLCReport” in the “Project Name” Field.

3. Select the “MM/DD/YYYY” as “Date Format”.

4. Click on “Theme” Button to set the theme for your project.

5. Select “Theme” as “Theme 2” and click on “Select” Button.

6. Select “Color Scheme 1” and click on “Ok” Button.

7. Browse the Project Path by clicking on “File Path” Button. Select the Path where you want to save the code generated by PrescientAuthor.

8. Select the “Server Name” as “Local”.

9. Enter “RDLCReport” in the “Database Name” Field.

10. Select “Use Windows Authentication” Radio Button.

11. Click on “Ok” Button.

3. Modeling Master Tables:


Create BookCategory Table

1. Right click on “Master Tables” menu in the tree and select “Create Table” or click on Master Tables from “Prescient Author Navigator” window.
2. Enter the table name ‘BookCategory’ in the “Table Name” Field.

3. Add field name “BookCategory” in the “Field Name” Field.  Select data type as varchar, enter size=50. Click on Add Field button.

4. Click on Add Table Button.


Create Book Table

1. Right click on “Master Tables” menu in the tree and select “Create Table” or click on Master Tables from “Prescient Author Navigator” window.

2. Enter the name ‘Book’ in the “Table Name” Field.

3. Add Field name “BookCategory” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “BookCategory” and click on “Add Field” Button

4. Add field name “Name” in the “Field Name” Field. Select data type as varchar, enter size=50. Click on Add Field button.

5. Add field name “Publication” in the “Field Name” Field.  Select data type as varchar, enter size=50. Click on Add Field button.

6. Add field name “Author” in the “Field Name” Field.  Select data type as varchar, enter size=50. Click on Add Field button.

7. Add field name “Price” in the “Field Name” Field.  Select data type as float, Click on Add Field button.

8. Click on Add Table Button.


Create Member Table

1. Right click on “Master Tables” menu in the tree and select “Create Table” or click on Master Tables from “Prescient Author Navigator” window.

2. Enter the table name “Member” in the “Table Name” Field.

3. Add field name “Name” in the “Field Name” Field.  Select data type as varchar, enter size=50. Click on Add Field button.

4. Add field name “Address” in the “Field Name” Field.  Select data type as varchar, enter size=500. Click on Add Field button.

5. Add field name “PhoneNo” in the “Field Name” Field.  Select data type as varchar, enter size=50. Click on Add Field button.

6. Click on Add Table Button.

4. Setting properties for the form controls: Author makes all the fields “Compulsory” by default. But we need to change this property for some controls. In this step we are changing this property.
Changing property for Book Master
1. Select “Book Form” from “Master Forms” menu.

2. Click on “Form Control” Button.

3. Double click on “Publication” field from “Form Control Names” List Box. “Manage Control Setting” dialog will be displayed.

4. Deselects the “Validate Field” Check box and click on “Ok” Button.

5. Double click on “Author” field from “Form Control Names” List Box. “Manage Control Setting” dialog will be displayed.

6. Deselects the “Validate Field” Check box and click on “Ok” Button.

7. Double click on “Price” field from “Form Control Names” List Box. “Manage Control Setting” dialog will be displayed.

8. Deselects the “Validate Field” Check box and click on “Ok” Button.

9. Click on “Ok” Button.

Changing property for Member Master
1. Select “Member Form” from “Master Forms” menu.

2. Click on “Form Control” Button.

3. Double click on “Address” field from “Form Control Names” List Box. “Manage Control Setting” dialog will be displayed.

4. Deselects the “Validate Field” Check box and click on “Ok” Button.

5. Double click on “PhoneNo” field from “Form Control Names” List Box. “Manage Control Setting” dialog will be displayed.

6. Deselects the “Validate Field” Check box and click on “Ok” Button.

7. Click on “Ok” Button.

5. Modeling Master Detail Tables: 


Create Issue_basic Table
1. Right click on “Master Detail Tables” menu in the tree and select “Create Table” or click on Master Detail Tables from “Prescient Author Navigator” window.

2. Enter the table name ‘Issue’ in the “Table Name” Field.

3. Add field name “Date” in the “Field Name” Field. Select data type as datetime. Click on Add Field button.

4. Add Field name “MemberName” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “Member” and click on “Add Field” Button.


Create Issue_detail Table
1. Select Issue_detail table.

2. Add Field name “BookCategory” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “BookCategory” and click on “Add Field” Button

3. Add Field name “Book” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “Book” and click on “Add Field” Button.


Create Return_basic Table
1. Right click on “Master Detail Tables” menu in the tree and select “Create Table”.

2. Enter the table name “Return” in the “Table Name” Field.

3. Add field name “Date” in the “Field Name” Field. Select data type as datetime. Click on Add Field button.


Create Return_detail Table
1. Select Return_detail table.

2. Add Field name “MemberName” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “Member” and click on “Add Field” Button.

3. Add Field name “BookCategory” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “BookCategory” and click on “Add Field” Button

4. Add Field name “Book” in the “Field Name” Field. Select data type as int. Select “Foreign Key” Checkbox and “Foreign Field Table” as “Book” and click on “Add Field” Button.

6. Creating database and Tables: This step is to create the database, and tables in the Microsoft SQL Server.

1. Click on “Tools -> Sync DB” menu from Author Main Window.

2. Click on “New Database” button.

3.  “Select Data Source” dialog will be displayed.

4. Click on “New” button. “Create New Data Source “dialog will be displayed.

5. Select the diver as “SQL Server” and click on “Next” Button.

6. Enter the name “MasterDataSource” in the text box and click on “Next” Button.

7. Click on “Finish” button.  “Create New Data Source to SQL Server “dialog will be displayed.

8. Select the server as”Local“from the “Server” combo box and click on “Next” button.

9. Select “With Windows NT Authentication” radio button and click on “Next” button.

10. Select the check box “Change default database to” and select the database “Master” from the combo box and click on “Next” button.

11. Click on “Finish” button.

12. Click on “Ok” button.

13. Select the “MasterDataSource” data source from the list and Click on “Ok” button.

14. The database will be created at the back end.

7. Generating Dot Net Code and Executing the code:

1. Click on “Output -> Write All” menu from Author Main Window.

2. The code for your project will be generated in the folder “Tutorial3”.

3. Open file “Tutorial3.sln in Microsoft Visual Studio 2005 editor”.

4. Click on “Debug” Button to execute the code.

8. Creating RDLC Reports:.
Creating “BookWiseIssuedOut” RDLC Report: In this step one report is created. This report accepts book name as a parameter and displays all the information about the member to whom the book is issued.

8.1. Creating “BookwiseIssuedOut” Dataset: Following are steps to create dataset needed for the RDLC Reports.

1. Right Click on “BaseModule -> Datasets” and Select Add -> New Item -> Dataset.

2. Write “BookwiseIssuedOut” in the “Name” Field and click on “Add” button

3. One file with the name “BookwiseIssuedOut.XSD” will be opened.

4. Right click in the “BookwiseIssuedOut.XSD” file and select “Add -> TableAdapter” or Click on “Toolbox” and double click on “TableAdapter”. 

5. “TableAdapter Configuration Wizard” dialog will be displayed, Click on “Next” button.

6. Select “Use SQL Statements” radio button and click on “Next” Button.

7. Write the following query in the text box 

"SELECT Issue_basic.Date, Member.Name +'('+PhoneNo+')' AS MemberName, Member.Address, Member.PhoneNo, Book.BookName, Book.BookCategory_id FROM Book INNER JOIN Issue_detail ON Book.Book_id = Issue_detail.Book_id INNER JOIN Issue_basic ON Issue_detail.Issue_id = Issue_basic.Issue_basic_id INNER JOIN Member ON Issue_basic.Member_id = Member.Member_id WHERE Issue_detail.Book_id = " + id +"";

8. Click on “Next” button.

9. Select “Fill a DataTable” and Return a DataTable” check boxes and Click on “Next” button.

10. Click on “Finish” Button.

8.2. Creating “BookwiseIssuedOut” RDLC: Following are steps to create RDLC file needed for the RDLC Reports.

11. Right Click on “BaseModule -> RDLC“and Select Add -> New Item -> Report.

12. Write “BookwiseIssuedOut” in the “Name” Field and click on “Add” button

13. One file with the name “BookwiseIssuedOut.RDLC” will be opened.

14. Open “Toolbox” window and double click on “Table”.

15. Click on “Data Menu -> Show Data Sources”. “Website Data sources” window will be opened.

16. Select “BookwiseIssuedOut -> Datatable1” data source.

17. Drag “Date” field and drop it on the column 1 and row 2 of the table we have created in the “BookwiseIssuedOut.RDLC” file.

18. Drag “MemberName” field and drop it on the column 2 and row 2 of the table we have created in the “BookwiseIssuedOut.RDLC” file.

19. Drag “Address” field and drop it on the column 3 and row 2 of the table we have created in the “BookwiseIssuedOut.RDLC” file.

20. Drag “BookName” field and drop it on the column 5 and row 2 of the table we have created in the “BookwiseIssuedOut.RDLC” file.

21. Save the file.

8.3. Modeling “BookwiseIssuedOut” RDLC report: 
1. Right Click on “RDLC Reports” from the tree menu and select “Create -> RDLC Report”. RDLC Report Definition dialog will be displayed.

2. Enter “BookwiseIssuedOutList” in the Report Name Field.

3. Enter “Book wise Issued out List Report” in the “Report Header” Field.

4. Click on “Synchronize” button.

5. Select “BookWiseIssuedOut.RDLC” from “Select RDLC” combo box and click on “Set RDLC” Report.

6. Click on “Reference Field” button. “Manage Reference Field” dialog will be displayed.

7. Enter BookCategory in the “Name” Field Select data type “varchar” and click on “Add” button.

8. Enter Book in the “Name” Field Select data type “varchar” and click on “Add” button.

9. Click on “Ok” button.

10. Click on “Form Controls” button. “Manage Form Controls” dialog will be displayed.

11. Select “BookCategory” from Field Name List box and click on “>” button.

12. Select “Book” from Field Name List box and click on “>” button.

13. Double click on “BookCategory” from “Form Control Name” List box. “Manage Control Setting” dialog will be displayed.

14. Select Control as “Combo box”.

15. Click on “Assign Function” button. “Assign Function” dialog will be displayed.

16. Module “BaseModule”, Class “BookCategory”, Function “SelectAllRecords” and click on “Ok” button.

17. Select Front Field as” Book.Name”, Back Field as” Book.Book_id” and Click on “Ok” Button.

18. Select Event “On Change”, select Changed control “Book” and click on “Add RecomputeField” button.
19. Click on “Ok” button.

20. Double click on “Book” from “Form Control Name” List box. “Manage Control Setting” dialog will be displayed.

21. Select Control as “Combo box”.

22. Click on “Assign Function” button. “Assign Function” dialog will be displayed.

23. Module “BaseModule”, Class “Book”, Function “SelectRecordForBookCategory_id”. The parameter for the function will be listed in the “Parameter” List box.
24. Select “id” form Parameter list box, select “BookCategory_id” from Fields List box and click on “>” button. 

25. Click on “Ok” button.

26. Select Front Field as” Book.Name”, Back Field as” Book.Book_id” and Click on “Ok” Button.

27. Click on “Ok” button.

28. Click on “@id” from “Query I/P Parameters” list box then click on “Book” from form control List box and click on “V” button. 

29. Click on “Ok” Button.

30. Click on “Output -> Write All” menu from Author Main Window.

31. The RDLC report file will be created.

